Язык
Контакты
GitHub
Поддержка
Регистрация
Войти
Логин: Пароль: Запомнить:
Пользователи
Последние сообщения
Тема закрыта
1 2

Тренажер мозгов, давайте думать над проблемой

Baxter

  • Свой человек
  • Юзер
  • 93
  • Репутация:2 
  • Предупреждения: 0 
  • Регистрация:
    1 Июл 2011
#1
Всем привет. Знаю какая тут хорошая поддержка, вот и обращаюсь.
Ставил я на серв много CMS и только Joomla, Drupal и DLE(Wordpress не пробовал) работают корректно. Но они мне не подходят, а вот Fapos это - легкость, бесплатность :0 , функциональность. Все что для меня нужно.
Но при установке двига на серв(раньше юзал на Денвере) он показывает главную страницу, а все остальных как бы нет.
Приблизительный текст:
Цитата
Not Found

The requested URL /forum/ was not found on this server.

Первый подозреваемый - .htaccess

Думаем :wall:

Drunya

  • Man of God
  • Админ
  • 3527
  • Репутация:110 
  • Предупреждения: 0 
  • Регистрация:
    30 Ноя -0001
#2
Baxter пишет:
Первый подозреваемый - .htaccess
ага. Rewrite Engine проверьте. Скорее всего он выключен или по каким то другим причинам не работает. Напишите админу, это минутное дело поправить.

Я горжусь тем, что создал бесплатную CMS - AtomX. И люблю нашу команду)

Baxter

  • Свой человек
  • Юзер
  • 93
  • Репутация:2 
  • Предупреждения: 0 
  • Регистрация:
    1 Июл 2011
#3
Он работает.

Кстати, чтобы лучше увидит о чем я говорю, вот сайт - http://gamesfan.zapto.org/

r00t_san

  • ДиЗиГнЕр
  • Пользователь
  • 169
  • Репутация:11 
  • Предупреждения: 0 
  • Регистрация:
    2 Окт 2010
#4
Baxter пишет:
Он работает.
Увы и ах.... он не работает.
http://gamesfan.zapto.org/index.php?url=forum
http://gamesfan.zapto.org/index.php?url=users
и.т.д....

Если где то нет чего то значит что то где то есть.

Baxter

  • Свой человек
  • Юзер
  • 93
  • Репутация:2 
  • Предупреждения: 0 
  • Регистрация:
    1 Июл 2011
#5
r00t_san, ну может и так.
Вроде бы все нормально. Но серв свой и самим тут не разобратся.
Возможно, часть опций .htaccess заблокированы и правила для модуля реврайт не применяются.
Может кто-то помочь с настройкой?

Drunya

  • Man of God
  • Админ
  • 3527
  • Репутация:110 
  • Предупреждения: 0 
  • Регистрация:
    30 Ноя -0001
#6
Baxter, надо просто включит реврайт и все. Так как видимо он вообще не работает.

Я горжусь тем, что создал бесплатную CMS - AtomX. И люблю нашу команду)

r00t_san

  • ДиЗиГнЕр
  • Пользователь
  • 169
  • Репутация:11 
  • Предупреждения: 0 
  • Регистрация:
    2 Окт 2010
#7
Baxter пишет:
Может кто-то помочь с настройкой?
Возможно это поможет.
Цитата
Here i am going to describe how to enable mod_rewrite in apache2.2 -specaily for debian.

In default installion of apache2.2 on debian never enable mod_rewrite default. So you may need to enable .

First install the apache2.2 with this command :
debian user please use “su” before start this process
ubuntu user please use “sudo su” before start this process

apt-get install apache2 (it will install apache 2.2)

on current debian system you can enable mod_rewrite with simple command

a2enmod rewrite

old style, you can skip this portion

now use locate to find if the mod_rewrite.so is availble on your server

updatedb
locate mod_rewrite.so

it will found in “/usr/lib/apache2/modules”

new apache follow some folders to enable and disable mods.
so now do this:

cd /etc/apache2/mods-enabled
touch rewrite.load
gedit rewrite.load (you may use any editor to edit this file)

now paste this following line

LoadModule rewrite_module /usr/lib/apache2/modules/mod_rewrite.so

end of old style

Then edit /etc/apache2/sites-available/default or /etc/apache2/sites-available/000-default (check which one available on your system)

Find the following

Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all

and change it to

Options Indexes FollowSymLinks MultiViews
AllowOverride all
Order allow,deny
allow from all

and finally restart Apache

/etc/init.d/apache2 restart
or
service apache2 restart

OK, you done

don’t forget to comment, if it works or not.

thanks.

Цитата
Baxter, надо просто включит реврайт и все. Так как видимо он вообще не работает.
Судя по всему на дебиане после установке апача по дефолту реврайт мод выключен, его надо врубить, см. выше. Надеюсь перевод не надо ?

Инфа 100%, нагуглено тут. http://www.lavluda.com/2007/07/15/how-to-enable-mod_rewrite-in-apache22-debian/

Отредактировано автором 22 Июл 2011
Если где то нет чего то значит что то где то есть.

Baxter

  • Свой человек
  • Юзер
  • 93
  • Репутация:2 
  • Предупреждения: 0 
  • Регистрация:
    1 Июл 2011
#8
Брат говорит что включен реврайт.

Вот после малых манипуляций - http://gamesfan.zapto.org/forum/

Добавлено2011.07.22 23-36

Ап gg)

Drunya

  • Man of God
  • Админ
  • 3527
  • Репутация:110 
  • Предупреждения: 0 
  • Регистрация:
    30 Ноя -0001
#9
Именно это и говорит о нерабочем хтаццесс.

Попробуй так:
Закомменти все что начинается с "php"
Закомменти RewriteBase /

Если не поможет значит сто пудово надо включить реврайт

Я горжусь тем, что создал бесплатную CMS - AtomX. И люблю нашу команду)

Baxter

  • Свой человек
  • Юзер
  • 93
  • Репутация:2 
  • Предупреждения: 0 
  • Регистрация:
    1 Июл 2011
#10
Ну там все что начиналось с "PHP" закомментино было.
Ну закомментил RewriteBase / - не помогло.

Вот доказательство что реврайт включен.
Code:
anton@mathsolve:~$ sudo a2enmod rewrite
[sudo] password for anton: 
Module rewrite already enabled
anton@mathsolve:~$

Добавлено2011.07.23 14-28

Может кому-то дать доступ, что бы разобраться? Может мы что-то не так делаем.

1 2
Сейчас online: 42. Зарегистрированных: 1. Гостей: 41.